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Episode 3: Transaction Manager - Full Transaction Cycle (Q&A) 

QUESTIONS AND ANSWERS 

When I click on a 

transaction within the grid 

on the Transactions page in 

Transaction Manager, 

another window opens. 

When I close the 

transaction, it remains 

locked and I cannot send. I 

then have to log out and 

then log back in to send. 

How can I close it without 

it becoming locked? 

If you are using the Transaction Manager cloud solution and not 

the desktop solution, you may need to clear your web browser 

cache and history, close out of all of your browser windows, and 

then start again. 

When the cursor is still on the transaction it will remain locked. 

NOTE: TrueCommerce recommends use of Google Chrome as 

your web browser. 

How can I make subfolders 

in the InBox and Received 

folders? 

On the Transactions page, highlight the main Transaction folder 

(Inbox, Received, Outbox, or Sent) to which you desire to add 

a subfolder, then click Options > New Folder on the actions 

bar. Enter a name for your folder in the field provided on the Add 

Folder pop-up, then click the OK button. Click the main folder (to 

which you just added the subfolder) to expand it and view your 

newly-created subfolder. 

Is there a list somewhere 

of what the various icons 

mean next to the 

transactions within the 

grid? 

Why does a red X appear on 

transactions in the Sent 

folder but not the Outbox? 

An updated was made since the document was received 

History of the document (click to view) 

Document was sent in Test mode (Typically utilized when a 

client is just finding out their compliance. Sending documents in 

test mode is practiced to ensure everything is copacetic before a 

client goes “live” with using Transaction Manager). 

NOTE: If no icon displays it means the document was sent in the 

Production environment. 

Trading partner has sent baseline requirements for return 

documents from their vendors. Required fields must be 

completed in the Transaction Details before you can send the 

document back to the partner. 

How do I change invoices 

that I sent from Test to 

Production mode? The 

client is still receiving the 

invoice regardless of the 

mode. 

To change the status of your transaction, navigate to the 

Trading Partner page from the primary navigation menu in 

Foundry, then click the desired partner name and select 

Preferences > Transactions. 

Under the Status tab, you can select the drop-down beside the 

Invoice and change it from Test to Production.  
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Episode 3: Transaction Manager - Full Transaction Cycle (Q&A) 

QUESTIONS AND ANSWERS 

 

How do I customize 

columns in the Transactions 

grid? 

If you mean how do you add or remove columns from the 

Transactions grid, you can click the horizontal ellipses on the 

right of any existing column to view the Sort (Asc or Desc), 

Columns, and Filter options. Click Columns to view the available 

columns that can be shown or hidden. Checking the box next to a 

column name will ensure it is displayed in the grid. 

 

If an update to an exported 

Purchase Order (PO) is 

sent, is it possible to 

update the PO in the 

business system? Is it 

possible to replace the 

original PO with the new 

one? 

There are a number of business systems that handle the PO 

Change request. 

Your TrueCommerce Manager can discuss these with you. To 

view their contact information, click Account Management in 

your Foundry primary navigation menu.  

Is there a simple way to 

print the raw data for a PO? 

Yes! 

Say, for example, you want to print a standard PDF. First, click 

the desired document in the Transactions grid, then select Print 

> PDF from action bar. This will display the legible PDF on one 

page. Alternatively, if you prefer to print the Raw EDI, select 

View > Raw EDI and then Select All of that content, copy it, 
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QUESTIONS AND ANSWERS 

and save it to a file (in Notepad, Word, or another preferred 

application). 

You can also navigate to Account Management > Account 

Overview via the primary navigation menu in Foundry to view 

Outbound documents that you sent. 

When we receive a new PO, 

should we be turning it 

around to tell the buyer we 

received the PO? 

Many Trading Partners want to have a PO Acknowledgment sent 

to them, but not all of them. 

Contact your Trading Partner to see if this is a requirement.  

When I am receiving POs in 

Production they switch to 

Test mode at the point that 

I turn the documents 

around. Should I contact 

my Account Manager to 

attempt to address this? 

Your outbound transactions need to be updated within 

Transaction Manager from Test to Production. 

To change the status of your transaction, navigate to the 

Trading Partner page from the primary navigation menu in 

Foundry, then click the desired partner name and select 

Preferences > Transactions. 

Under the Status tab, you can select the drop-down beside the 

Invoice and change it from Test to Production.  

 

When I turnaround orders I 

lose the line numbers in the 

Items tab and have to re-

enter them all manually. Is 

there a way to reload that? 

Yes! 

If your Trading Partner is live, contact the TrueCommerce 

Support team. They can submit a mapping request to have the 

line numbers carry over from one transaction to the other.  

When I receive an order, 

can I export it as an Excel 

doc? 

Yes! 

To do this, double-click on the desired order within the Received 

folder on the Transactions page to open the order (Transaction) 

Details, then select View > History Report from the action bar. 

A Generating Report pop-up will display, then show the 

Transaction History Report for the order. 

To export it to Excel, select File > Export from the action bar. 

The order will be downloaded in Excel format to your computer. 

Regarding the Accounts 

Payable function: If a 

vendor is not EDI 

compatible, is there an 

option to scan an Invoice 

TrueCommerce has the ability to receive transactions via email 

and have them generated within Transaction Manager or sent 

from Transaction Manager. 

We recommend you reach out to your Account Manager on this 

question. Their contact information can be found under Account 

Management in the Foundry primary menu. 

mailto:Support@truecommerce.com
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QUESTIONS AND ANSWERS 

using Optical Character 

Recognition (OCR)? 

Is there a way to 

simultaneously open two 

different tabs in 

Transaction Manager in 

order to compare one 

transaction to another and 

be able to see both at the 

same time? 

Can you open multiple POs 

simultaneously to view the 

RAW data? 

Yes! 

From the Foundry primary navigation menu, navigate to 

Administration > System Configuration, then uncheck the 

Single Window box. Afterwards, when you double-click on a 

transaction, it will open in another tab.  

Is there a way to send 

multiple documents 

simultaneously? Is this 

something we can set up? 

When we select more than 

one file, each file is 

overwritten by the next 

order. The system yields an 

error about a unique name. 

How do we assign a unique 

file name? 

Yes! 

From the Foundry primary navigation menu, click Business 

System. On the Business System page, click the desired 

company name to navigate to the System Setup screen. Here, 

you will see the Export File Type Names section. You can select 

the Use Unique File Name checkbox. 

Additionally, you can go to the Export File Custom Naming 

section below it and choose additional information to make the 

file name unique outside of just using the unique date/time.  

Is there a way to refuse a 

PO? Sometimes, we update 

our pricing and the client 

sends a PO with the old 

pricing. Is there a way to 

notify the client through 

TrueCommerce? 

It depends on your Trading Partner. If you are not sure how the 

partner is expecting to see the data, you could get a charge back 

or a rejection, for example. Therefore, it is essential that you 

communicate with your partner directly before you send anything 

back. 

TrueCommerce does have documents you can send for that data; 

often, it is the PO Acknowledgement (EDI 855). Additionally, the 

Functional Acknowledgement (EDI 997/Receipt) is sent 

automatically by the system. 

The 855 notifies the partner of whether you can or cannot fulfill 

an order. Under Template > Main tab, choose what kind of 

Acknowledgement you are sending back (Ack Detail – no change; 

Ack Detail with change available for 855) and also provide Item 

> Status (Item Accepted – Price Changed). If you are sending 

back a change, you must provide a status for it. 

If the Transaction Type 

name in the Outbox is 

different from the 

Transaction Type name 

Contact the TrueCommerce Support team on this, as there may 

be an option to have this scenario reviewed by our Mapping team 

in order to rename it. 

mailto:Support@truecommerce.com
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QUESTIONS AND ANSWERS 

within Transaction setup, 

how do I fix it? 

If a document has an error, 

where can I find the details 

of the error from my 

trading partner? 

Some Trading Partners, but not all, will send back a negative 

Functional Acknowledgement (997). Find the transaction in your 

Transactions ‘Sent’ folder, then select View > Transaction 

History. Here, you can see the associated 997 back from the 

Trading Partner. Select that 997 and then once you are in the 

Transaction View, you can select View > Raw EDI. Here, you 

will see the negative 997 values.   

Would the PO 

Acknowledgement (855) 

change be relative to the 

purpose code and partner 

needs to be setup to 

accept? 

Yes. 

This could be a condition that is not configured appropriately. You 

should contact your Trading Partner to coordinate the value.  

If I do a turnaround is 

there a possibility of 

creating a duplicate order? 

You can only create Outbound documents on Turnaround. 

If your PO is an Inbound document, it is not possible to create 

another inbound document in your Transactions Outbox. 

Won’t resending a Sent 

document cause a duplicate 

number error? 

This can depend on the Trading Partner. 

Some key off of the Document Number and some key off of the 

control numbers. It is a case-by-case basis whenever you need to 

resend a transaction. If your original transaction failed on the 

Trading Partner’s side, a ‘fixed’ with the same Doc Number will 

typically be accepted. 

It is always best to contact your Trading Partner to understand 

their rules.  

How long do documents 

stay in the Transaction 

folders (Deleted folder)? Do 

older documents get 

archived? 

In our experience, 

transactions older than six 

months are purged from 

Transaction Manager 

(Received and Sent 

folders). Is there a way to 

expand the timeframe 

before transactions are 

purged? Marianna said they 

stay in Received forever, so 

It is likely that your documents are being automatically archived 

if they are no longer available after six months. 



 

 

 











 

 

6 Proprietary and Confidential 
© 1998-2022 TrueCommerce, Inc. All rights reserved. 

Episode 3: Transaction Manager - Full Transaction Cycle (Q&A) 

QUESTIONS AND ANSWERS 

just wondering if 

something has changed? 

I’m having an issue where 

the business name has not 

populated for test files I’ve 

received. How do I get it to 

populate so I can import 

the test POs into my ERP? 

This sounds like the Trading Partner is not associated to an ID 

within Transaction Manager. 

From the Foundry primary navigation menu, navigate to 

Business System and click the desired company name, then 

select Company Configuration > EDI Setup and ensure the ID 

associated with the partner is checked.  

My turnaround transactions 

go to the Transactions 

Outbox. Is this correct, or 

should I be performing 

another step? 

Yes! This is correct.  

Is there a way to hide 

unused transactions in the 

transaction turnaround 

screen? 

Navigate to the primary navigation menu and select Trading 

Partners, then click the desired partner on the Trading Partner 

page. Select Preferences > Transactions from the drop-down 

to view all of the documents you can receive on the Transaction 

Setup page. 

The far left column icons are indictors of whether the document is 

inbound or outbound. Check the box in the Active column to 

make the outbound document available to you in your turnaround 

menu or uncheck it to remove it from the turnaround menu 

(although you can always come back and re-add it later). 

NOTE: This is where you can also set if the document will be in 

Test or Production mode using the checkbox within the 

Test/Production column. 

If there is mapping in the 

background, does it 

overwrite what you put in 

the template? 

Yes, it does. 

Will copying to the Outbox 

to fix a mistake “take back” 

the incorrect document 

sent to the Trading 

Partner? Or does the 

Trading Partner still see the 

incorrect document and the 

revised document? 

The Trading Partner will see both. 

I have been told not to click 

the Export button on the 

action bar but rather to 

click Actions > Export and 

Either way, it is the same functionality. 

By the way, you can export more than one document if you so 

choose by clicking the Ctrl key on your computer keyboard and 
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QUESTIONS AND ANSWERS 

perform the export that 

way. Why would that be or 

what is the difference?  

then select multiple documents in the Transactions grid for export 

before clicking Export or Actions > Export. 

NOTE: This is not the same as Asynchronous Export. 

How do I export integration 

errors to Excel? Is there a 

way to identify a spoke in 

particular errors? 

Unfortunately, there is no way to do this.  

Is it up to the Trading 

Partner whether you can 

resend an Invoice? 

Yes, it is up to the Trading Partner. 

Can you change the order 

of how things are sorted in 

the Sent folder 

(alphabetically, for 

example, instead of by 

date)? 

The filtering will always default to the Date Sent. If you click on 

any column you can filter accordingly while in that folder. 

What do you do if you click 

the wrong turnaround? 

What if you click Shipment 

instead of post allocation? 

You can click the Back or Cancel button. 

Will there be more 

webinars soon? 

Yes! 

Soon, we will curate and coordinate a Winter series that will 

include a fresh set of topics. You can keep on the lookout for any 

upcoming (or past/recorded webinars) by searching the Help 

Articles under the question mark icon in the top right of the 

screen when you are logged into Foundry. 

Meanwhile, following are the Fall and Summer Webinar Series 

articles, which include links to past/recorded and upcoming 

webinars: 

• TrueCommerce Webinar Series: Fall 2022 

• TrueCommerce Webinar Series: Summer 2022 

 

http://help.truecommerce.com/en/articles/6526327-truecommerce-webinar-series-fall-2022
https://help.truecommerce.com/en/articles/6252534-transaction-manager-webinar-series

